<!DOCTYPE html><html lang="en-US"><head><link rel="stylesheet" type="text/css" href="http://www.codesimplicity.com/wp-content/cache/minify/be7d4.css" media="all" /><meta charset="UTF-8"><title>Code Simplicity &raquo; The Fundamental Philosophy of Debugging</title><meta name="author" content="Maxwell Kanat-Alexander"><meta name="copyright" content="&copy; 2008-2012 Max Kanat-Alexander"><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.codesimplicity.com/xmlrpc.php"><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//s.gravatar.com' /><link rel='dns-prefetch' href='//www.googleadservices.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Code Simplicity &raquo; Feed" href="http://www.codesimplicity.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Code Simplicity &raquo; Comments Feed" href="http://www.codesimplicity.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Code Simplicity &raquo; The Fundamental Philosophy of Debugging Comments Feed" href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.codesimplicity.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='codesimplicity-fonts-css'  href='//fonts.googleapis.com/css?family=Oxygen|Open+Sans' type='text/css' media='all' /> <script type="text/javascript" data-cfasync="false">// Function to detect opted out users
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	// Disable tracking if the opt-out cookie exists.
	var disableStr = 'ga-disable-UA-42553676-6';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	// Opt-out function
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-42553676-6', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');</script>  <script type='text/javascript'>/*  */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"\/buy-book\/,\/book\/","home_url":"http:\/\/www.codesimplicity.com","track_download_as":"event","internal_label":"book","hash_tracking":"false"};
/*  */</script> <script type="text/javascript" src="http://www.codesimplicity.com/wp-content/cache/minify/43094.js"></script> <link rel='https://api.w.org/' href='http://www.codesimplicity.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.codesimplicity.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.codesimplicity.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Refactoring is About Features' href='http://www.codesimplicity.com/post/refactoring-is-about-features/' /><meta name="generator" content="WordPress 4.8" /><link rel="canonical" href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" /><link rel='shortlink' href='http://wp.me/p7UHy5-qQ' /><link rel="alternate" type="application/json+oembed" href="http://www.codesimplicity.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.codesimplicity.com%2Fpost%2Fthe-fundamental-philosophy-of-debugging%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.codesimplicity.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.codesimplicity.com%2Fpost%2Fthe-fundamental-philosophy-of-debugging%2F&#038;format=xml" /><link rel='dns-prefetch' href='//v0.wordpress.com'><style type='text/css'>img#wpstats{display:none}</style><meta property="og:type" content="article" /><meta property="og:title" content="The Fundamental Philosophy of Debugging" /><meta property="og:url" content="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" /><meta property="og:description" content="Sometimes people have a very hard time debugging. Mostly, these are people who believe that in order to debug a system, you have to think about it instead of looking at it. Let me give you an examp…" /><meta property="article:published_time" content="2017-07-18T00:39:52+00:00" /><meta property="article:modified_time" content="2017-07-18T00:54:04+00:00" /><meta property="og:site_name" content="Code Simplicity" /><meta property="og:image" content="http://www.codesimplicity.com/wp-content/uploads/2017/04/cropped-img_3651.jpg" /><meta property="og:image:width" content="512" /><meta property="og:image:height" content="512" /><meta property="og:locale" content="en_US" /><meta name="twitter:site" content="@mkanat" /><meta name="twitter:card" content="summary" /><link rel="icon" href="http://www.codesimplicity.com/wp-content/uploads/2017/04/cropped-img_3651-32x32.jpg" sizes="32x32" /><link rel="icon" href="http://www.codesimplicity.com/wp-content/uploads/2017/04/cropped-img_3651-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="http://www.codesimplicity.com/wp-content/uploads/2017/04/cropped-img_3651-180x180.jpg" /><meta name="msapplication-TileImage" content="http://www.codesimplicity.com/wp-content/uploads/2017/04/cropped-img_3651-270x270.jpg" /></head><body class="post-template-default single single-post postid-1664 single-format-standard"><h1><a href="http://www.codesimplicity.com/" rel="home">Code Simplicity</a></h1><div id="content"><div id="rightcontent"><div id="bookcover"> <a onclick="goog_report_conversion('http://www.codesimplicity.com/buy-book/');fbq('track', 'ViewContent');" href="/buy-book/"> <img width="200" alt="Code Simplicity: The Fundamentals of Software" src="/wp-content/themes/codesimplicity/book.jpg"> <br>Get the Book </a></div><ul id="menu"><li class="blog"><a href="/">Blog</a></li><li class="about"><a href="/about/">About</a></li><li class="speaking"><a href="/contact/">Contact</a></li><li class="subscribe"><a href="/feed/atom/">Subscribe             <img alt="(Atom)" src="/wp-content/themes/codesimplicity/feed.png"></a></li></ul><div id="twitterheader"> <a href="http://twitter.com/mkanat">@mkanat</a> <a href="http://twitter.com/mkanat" id="twitter-follow-mkanat" class="twitter-follow-button" data-show-count="false" data-show-screen-name="false">Follow</a></div><div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary"><div><span class="widget_title"></span><a class="twitter-timeline" data-width="220" data-height="400" data-theme="light" data-link-color="#26a" data-border-color="#e8e8e8" data-lang="EN" data-chrome="noheader nofooter noborders transparent" href="https://twitter.com/mkanat">My Tweets</a></div></div></div><div id="leftcontent"><div id="post-1664" class="post-1664 post type-post status-publish format-standard hentry category-essays"><div class="entry-header"><div class="entry-meta"> <a href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" title="4:39 pm" rel="bookmark"><span class="entry-date">July 17, 2017</span></a></div><h2 class="entry-title"> <a href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" title="Permalink to The Fundamental Philosophy of Debugging" rel="bookmark">The Fundamental Philosophy of Debugging</a></h2></div><div class="entry-content"><p>Sometimes people have a very hard time debugging. Mostly, these are people who believe that in order to debug a system, you have to <em>think</em> about it instead of <em>looking</em> at it.</p><p>Let me give you an example of what I mean. Let&#8217;s say you have a web server that is silently failing to serve pages to users 5% of the time. What is your reaction to this question: &#8220;Why?&#8221;</p><p>Do you immediately try to come up with some answer? Do you start guessing? If so, you are doing the wrong thing.</p><p>The right answer to that question is: <strong>&#8220;I don&#8217;t know.&#8221;</strong></p><p>So this gives us the first step to successful debugging: <span id="more-1664"></span></p><blockquote><p> <strong>When you start debugging, realize that you do not already know the answer.</strong></p></blockquote><p>It can be tempting to think that you already know the answer. Sometimes you can guess and you&#8217;re right. It doesn&#8217;t happen very often, but it happens often enough to trick people into thinking that <em>guessing the answer</em> is a good method of debugging. However, most of the time, you will spend hours, days, or weeks guessing the answer and trying different fixes with no result other than complicating the code. In fact, some codebases are full of &#8220;solutions&#8221; to &#8220;bugs&#8221; that are actually just guesses&#8212;and these &#8220;solutions&#8221; are a significant source of complexity in the codebase.</p><p>Actually, as a side note, I&#8217;ll tell you an interesting principle. Usually, if you&#8217;ve done a good job of fixing a bug, you&#8217;ve actually caused some part of the system to go away, become simpler, have better design, etc. as part of your fix. I&#8217;ll probably go into that more at some point, but for now, there it is. Very often, the best fix for a bug is a fix that actually deletes code or simplifies the system.</p><p>But getting back to the process of debugging itself, what <em>should</em> you do? Guessing is a waste of time, imagining reasons for the problem is a waste of time&#8212;basically most of the activity that happens <em>in your mind</em> when first presented with the problem is a waste of time. The only things you have to do with your mind are:</p><ol><li>Remember what a working system behaves like.</li><li>Figure out what you need to look at in order to get more data.</li></ol><p>Because you see, this brings us to the most important principle of debugging:</p><blockquote><p> <strong>Debugging is accomplished by gathering data until you understand the cause of the problem.</strong></p></blockquote><p>The way that you gather data is, almost always, by <em>looking</em> at something. In the case of the web server that&#8217;s not serving pages, perhaps you would look at its logs. Or you could try to reproduce the problem so that you can look at what happens with the server when the problem is happening. This is why people often want a &#8220;reproduction case&#8221; (a series of steps that allow you to reproduce the exact problem)&#8212;so that they can <em>look</em> at what is happening when the bug occurs.</p><p>Sometimes the first piece of data you need to gather is what the bug <em>actually is</em>. Often users file bug reports that have insufficient data. For example, let&#8217;s say a user files the bug, &#8220;When I load the page, the web server doesn&#8217;t return anything.&#8221; That&#8217;s not sufficient information. What page did they try to load? What do they mean by &#8220;doesn&#8217;t return anything?&#8221; Is it just a white page? You might <em>assume</em> that&#8217;s what the user meant, but very often your assumptions will be incorrect. The less experienced your user is as a programmer or computer technician, the less well they will be able to express specifically what happened without you questioning them. In these cases, unless it&#8217;s an emergency, the first thing that I do is just send the user back specific requests to clarify their bug report, and leave it at that until they respond. I don&#8217;t look into it <em>at all</em> until they clarify things. If I did go off and try to solve the problem before I understood it fully, I could be wasting my time looking into random corners of the system that have nothing to do with any problem at all. It&#8217;s better to go spend my time on something productive while I wait for the user to respond, and then when I <em>do</em> have a complete bug report, to go research the cause of the now-understood bug.</p><p>As a note on this, though, don&#8217;t be rude or unfriendly to users just because they have filed an incomplete bug report. The fact that you know more about the system and they know less about the system doesn&#8217;t make you a superior being who should look down upon all users with disdain from your high castle on the shimmering peak of Smarter-Than-You Mountain. Instead, ask your questions in a kind or straightforward manner and just get the information. Bug filers are rarely intentionally being stupid&#8212;rather, they simply don&#8217;t know and it&#8217;s part of your job to help them provide the right information. If people frequently don&#8217;t provide the right information, you can even include a little questionnaire or form on the bug-filing page that makes them fill in the right information. The point is to be helpful to them so that they can be helpful to you, and so that you can easily resolve the issues that come in.</p><p>Once you&#8217;ve clarified the bug, you have to go and look at various parts of the system. <em>Which</em> parts of the system to look at is based on your knowledge of the system. Usually it&#8217;s logs, monitoring, error messages, core dumps, or some other output of the system. If you don&#8217;t <em>have</em> these things, you might have to launch or release a new version of the system that provides the information before you can fully debug the system. Although that might seem like a lot of work just to fix a bug, in reality it often ends up being faster to release a new version that provides sufficient information than to spend your time hunting around the system and guessing what&#8217;s going on without information. This is also another good argument for having fast, frequent releases&#8212;that way you can get out a new version that provides new debugging information quickly. Sometimes you can get a new build of your system out to just the user who is experiencing the problem, too, as a shortcut to get the information that you need.</p><p>Now, remember above that I mentioned that you have to remember what a working system looks like? This is because there is another principle of debugging:</p><blockquote><p> <strong>Debugging is accomplished by comparing the data that you have to what you know the data from a working system should look like.</strong></p></blockquote><p>When you see a message in a log, is that a normal message or is it actually an error? Maybe the log says, &#8220;Warning: all the user data is missing.&#8221; That looks like an error, but really your web server prints that every single time it starts. You have to know that a <em>working</em> web server does that. You&#8217;re looking for behavior or output that a <em>working</em> system does not display. Also, you have to understand what these messages <em>mean</em>. Maybe the web server optionally has some user database that you aren&#8217;t using, which is why you get that warning&#8212;because you <em>intend</em> for all the &#8220;user data&#8221; to be missing.</p><p>Eventually you will find something that a working system does not do. You shouldn&#8217;t immediately assume you&#8217;ve found the cause of the problem when you see this, though. For example, maybe it logs a message saying, &#8220;Error: insects are eating all the cookies.&#8221; One way that you could &#8220;fix&#8221; that behavior would be to delete the log message. Now the behavior is like normal, right? No, wrong&#8212;the actual bug is still happening. That&#8217;s a pretty stupid example, but people do less-stupid versions of this that don&#8217;t fix the bug. They don&#8217;t get down to the <a href="http://www.codesimplicity.com/post/make-it-never-come-back/">basic cause of the problem</a> and instead they paper over the bug with some workaround that lives in the codebase forever and causes complexity for everybody who works on that area of the code from then on. It&#8217;s not even sufficient to say &#8220;You will know that you have found the real cause because fixing that fixes the bug.&#8221; That&#8217;s pretty <em>close</em> to the truth, but a closer statement is, &#8220;You will know that you have found a real cause when you are confident that fixing it will make the problem <a href="http://www.codesimplicity.com/post/make-it-never-come-back/">never come back</a>.&#8221; This isn&#8217;t an absolute statement&#8212;there is a sort of scale of how &#8220;fixed&#8221; a bug is. A bug can be more fixed or less fixed, usually based on how &#8220;deep&#8221; you want to go with your solution, and how much time you want to spend on it. Usually you&#8217;ll know when you&#8217;ve found a decent cause of the problem and can now declare the bug fixed&#8212;it&#8217;s pretty obvious. But I wanted to warn you against papering over a bug by eliminating the symptoms but not handling the cause.</p><p>And of course, once you have the cause, you fix it. That&#8217;s actually the simplest step, if you&#8217;ve done everything else right.</p><p>So basically this gives us four primary steps to debugging:</p><ol><li>Familiarity with what a working system does.</li><li>Understanding that you don&#8217;t already know the cause of the problem.</li><li>Looking at data until you know what causes the problem.</li><li>Fixing the cause and not the symptoms.</li></ol><p>This sounds pretty simple, but I see people violate this formula all the time. In my experience, <em>most</em> programmers, when faced with a bug, want to sit around and think about it or talk about what might be causing it&#8212;both forms of guessing. It&#8217;s okay to talk to other people who might have information about the system or advice on where to look for data that would help you debug. But sitting around and <em>collectively</em> guessing what could cause the bug isn&#8217;t really any better than sitting around and doing it yourself, except perhaps that you get to chat with your co-workers, which could be good if you like them. Mostly though what you&#8217;re doing in that case is wasting a bunch of people&#8217;s time instead of just wasting your own time.</p><p>So don&#8217;t waste people&#8217;s time, and don&#8217;t create more complexity than you need to in your codebase. This debugging method works. It works every time, on every codebase, with every system. Sometimes the &#8220;data gathering&#8221; step is pretty hard, particularly with bugs that you can&#8217;t reproduce. But at the worst, you can gather data by looking at the code and trying to see if you can <em>see</em> a bug in it, or draw a diagram of how the system behaves and see if you can perceive a problem there. I would only recommend that as a last resort, but if you have to, it&#8217;s still better than guessing what&#8217;s wrong or assuming you already know.</p><p>Sometimes, it&#8217;s almost magical how a bug resolves just by looking at the right data until you <em>know</em>. Try it for yourself and see. It can actually be fun, even.</p><p>-Max</p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" data-layout="button_count"></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" data-counter="right"></script></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/" data-text="The Fundamental Philosophy of Debugging" data-via="mkanat" >Tweet</a></li><li class="share-custom share-custom-hackernews"><a rel="nofollow" data-shared="" class="share-custom share-custom-hackernews sd-button" href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/?share=custom-1492099929" target="_blank" title="Click to share on Hacker News"><span style="background-image:url(&quot;https://news.ycombinator.com/y18.gif&quot;);">Hacker News</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><div class="reddit_button"><iframe src="http://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=http%3A%2F%2Fwww.codesimplicity.com%2Fpost%2Fthe-fundamental-philosophy-of-debugging%2F&amp;title=The%20Fundamental%20Philosophy%20of%20Debugging" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/"></div></div></li><li class="share-end"></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button" href="whatsapp://send?text=The%20Fundamental%20Philosophy%20of%20Debugging http%3A%2F%2Fwww.codesimplicity.com%2Fpost%2Fthe-fundamental-philosophy-of-debugging%2F" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div></div></div></div></div><div id="comments"><h3 id="comments-title">3 Responses to <em>The Fundamental Philosophy of Debugging</em></h3><ol class="commentlist"><li class="post pingback"><p>Pingback: <a href='http://blog.explodingads.com/?p=339263' rel='external nofollow' class='url'>1 – The Fundamental Philosophy of Debugging</a></p></li><li class="comment even thread-even depth-1" id="li-comment-761537"><div id="comment-761537"><div class="comment-author vcard"> <img alt='' src='http://0.gravatar.com/avatar/038e50cfc2dc153ebae742ca43b31785?s=40&#038;d=identicon&#038;r=g' srcset='http://0.gravatar.com/avatar/038e50cfc2dc153ebae742ca43b31785?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Steven Gordon</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"><a href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/#comment-761537"> July 17, 2017 at 9:03 pm</a></div><div class="comment-body"><p>Two things come to mind:</p><p>1. There is no way to estimate how long it will take to fix a bug, because most of the work is diagnosis.  You cannot know ahead of time what the diagnosis will entail because you cannot know what you do not yet know.  After you arrive at a diagnosis supported by observation, then you should be able to give a reasonable estimate of how long it will take to fix, but by then you have already done most of the work.</p><p>2. Before doing the diagnosis step so well described in this article, I do suggest writing automated tests that cover the cases that fail due to the bug.  This not only helps you know when you have fixed the bug, but the accumulative automated tests for previous bugs validate that you have not undone the fix for some other bug.  Bugs are well known to exhibit recidivism.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/?replytocom=761537#respond' onclick='return addComment.moveForm( "comment-761537", "761537", "respond", "1664" )' aria-label='Reply to Steven Gordon'>Reply</a></div></div><ul class="children"><li class="comment byuser comment-author-admin bypostauthor odd alt depth-2" id="li-comment-761538"><div id="comment-761538"><div class="comment-author vcard"> <img alt='' src='http://1.gravatar.com/avatar/189e700a1367072d494a1b33ee94cbda?s=40&#038;d=identicon&#038;r=g' srcset='http://1.gravatar.com/avatar/189e700a1367072d494a1b33ee94cbda?s=80&amp;d=identicon&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' />			<cite class="fn">Max Kanat-Alexander</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"><a href="http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/#comment-761538"> July 17, 2017 at 9:35 pm</a></div><div class="comment-body"><p>Hey Steven! Agreed on both counts. The only caveat I would provide is that when you write the tests, you shouldn&#8217;t <em>just</em> write &#8220;regression tests&#8221; reactively in response to bugs, but rather good-coverage and well-designed unit tests that expose the bug by the nature of being generally well-designed tests. This doesn&#8217;t mean that sometimes you don&#8217;t need to add another case to your unit tests when a new bug is found, but it means that the base tests should be designed surrounding the basic principles of testing.</p><p>-Max</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='http://www.codesimplicity.com/post/the-fundamental-philosophy-of-debugging/?replytocom=761538#respond' onclick='return addComment.moveForm( "comment-761538", "761538", "respond", "1664" )' aria-label='Reply to Max Kanat-Alexander'>Reply</a></div></div></li></ul></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/post/the-fundamental-philosophy-of-debugging/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=the-fundamental-philosophy-of-debugging#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.codesimplicity.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1664' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2f9721b64e" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="59"/></p></form></div></div></div></div> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1489762511054114&ev=PageView&noscript=1"/></noscript> <script type="text/javascript">/*  */
  goog_snippet_vars = function() {
    var w = window;
    w.google_conversion_id = 1050117960;
    w.google_conversion_label = "fZ1wCJW0pnAQyI7e9AM";
    w.google_remarketing_only = false;
  }
  // DO NOT CHANGE THE CODE BELOW.
  goog_report_conversion = function(url) {
    goog_snippet_vars();
    window.google_conversion_format = "3";
    var opt = new Object();
    opt.onload_callback = function() {
    if (typeof(url) != 'undefined') {
      window.location = url;
    }
  }
  var conv_handler = window['google_trackConversion'];
  if (typeof(conv_handler) == 'function') {
    conv_handler(opt);
  }
}
/*  */</script> <div style="display:none"><div class="grofile-hash-map-038e50cfc2dc153ebae742ca43b31785"></div><div class="grofile-hash-map-189e700a1367072d494a1b33ee94cbda"></div></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"http:\/\/www.codesimplicity.com\/post\/the-fundamental-philosophy-of-debugging\/":1664};</script> <script type="text/javascript">var windowOpen;
		jQuery(document.body).on('click', 'a.share-facebook', function() {
			if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
				windowOpen.close();
			}
			windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
			return false;
		});</script> <div id="fb-root"></div> <script>/*<![CDATA[*/(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));/*]]>*/</script> <script>jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );</script> <script type="text/javascript">jQuery( document ).ready( function() {
			    jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
			        IN.init();
			    });
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});</script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script> <div id="sharing_email" style="display: none;"><form action="/post/the-fundamental-philosophy-of-debugging/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=the-fundamental-philosophy-of-debugging" method="post"> <label for="target_email">Send to Email Address</label> <input type="email" name="target_email" id="target_email" value="" /> <label for="source_name">Your Name</label> <input type="text" name="source_name" id="source_name" value="" /><label for="source_email">Your Email Address</label> <input type="email" name="source_email" id="source_email" value="" /><input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" /> <script>document.getElementById('jetpack-source_f_name').value = '';</script> <img style="float: right; display: none" class="loading" src="http://www.codesimplicity.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" /> <input type="submit" value="Send Email" class="sharing_send" /> <a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a><div class="errors errors-1" style="display: none;"> Post was not sent - check your email addresses!</div><div class="errors errors-2" style="display: none;"> Email check failed, please try again</div><div class="errors errors-3" style="display: none;"> Sorry, your blog cannot share posts by email.</div></form></div> <script>function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );</script> <script async type="text/javascript" src="http://www.codesimplicity.com/wp-content/cache/minify/9c5e7.js"></script> <script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201729'></script> <script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Julaa'></script> <script type='text/javascript'>/*  */
var WPGroHo = {"my_hash":""};
/*  */</script> <script async type="text/javascript" src="http://www.codesimplicity.com/wp-content/cache/minify/eeb84.js"></script> <script type='text/javascript' src='//www.googleadservices.com/pagead/conversion_async.js'></script> <script async type="text/javascript" src="http://www.codesimplicity.com/wp-content/cache/minify/fe2ce.js"></script> <script type='text/javascript'>/*  */
var sharing_js_options = {"lang":"en","counts":"1"};
/*  */</script> <script async type="text/javascript" src="http://www.codesimplicity.com/wp-content/cache/minify/337c6.js"></script> <script type='text/javascript' src='http://stats.wp.com/e-201729.js' async defer></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.3.1',blog:'116948125',post:'1664',tz:'-8',srv:'www.codesimplicity.com'} ]);
	_stq.push([ 'clickTrackerInit', '116948125', '1664' ]);</script> </body></html>